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1. Understand on Toolbar 

 

1.1 Report Object 

 

Icon Name Description 

 Object Selection standard mode of operation : mouse cursor selects object(s), modifies 

their sizes, etc. 

 
Hand allows dragging of whole report page 

 
Zoom allows left-clicking to zoom in (adds 25% if already 25-75%, else adds 

100%) or right-clicking to zoom out (subtracts 25% if already 50-

100%, else subtracts 100%) holding left mouse button while dragging 

zooms in to selected area 

 
Text Editor allows in-place editing of “Text” object holding left mouse button and 

moving the cursor creates and sizes a new “Text” object and opens its 

editor 

 
Format copying allows Format copying from one "Text" object to others: select a 

“Text” object, click Format mode button, select Target "Text" objects 

in turn exit Format copying mode by clicking any other mode button 

 
Band  an area on a design page which behaves according to its type (e.g. 

Header band, Data band) 

 
Text displays one or more lines of text within a rectangular area 

 
Picture displays a graphic file in “BMP,” “JPEG,” “ICO,” “WMF” or “EMF” 

format 

 
SubReport allows insertion of another report design page(New Page) within the 

host page. 

 
System Text displays either system information (date, time, page number, sum, etc) 

or aggregate values 

 
Check Box displays a checkbox with either a tick or a cross 

 
Chart displays data in various chart formats (pie chart, histogram, etc.) 

 
RichText displays text in Rich Text Format (RTF) 

 
Draw displays a horizontal or vertical line and 

displays various geometrical shapes (diagonal line, rectangle, rounded 

rectangle, ellipse, triangle and diamond) 

 
Barcode displays data as one of several barcode types 
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1.2 Align Toolbar 

 

Icon Name Description 

 Align Left align left edges (to first selected object) 

 
Align Middle align horizontal centres (to first selected 

 
Align Right align right edges (to first selected object) 

 
Align Top align top edges (to first selected object) 

 
Align Centre align vertical centres (to first selected object) 

 
Align Bottom align bottom edges (to first selected object) 

 
Space Horizontally space equally in horizontal direction 

 
Space Vertically space equally in vertical direction 

 
Centre Horizontally individually centre each object horizontally in band 

 
Centre Vertically individually centre each object vertically in band 

 
Shrink/Grow Width to 

Smaller/Larger 

set equal widths (same as first selected object) 

 
Shrink/Grow Height to 

Smaller/Larger 

set equal heights (same as first selected object) 
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2. Sales Invoice Bands 

2.1 Understand on Bands 

 

2.1.1 Group Header 

-  Grouping Header 

- To Print on every page, right click on Group Header Band, select reprint on new page  

2.1.2 Master Data 

- The Main Dataset of the report  

- Normally Bind to Main Dataset  

- Each Page allows to have 1 Main Dataset Only 

 

2.1.3 Detail Data 

- To display all Item Details 

2.1.4 Group Footer 

- Grouping Footer 

- Display on Last Page only  

2.1.5 Page Footer 

- Display on Every Pages 
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2.2 Sample Layout in Design Mode 

 

  

 

 

 

 

 

Group Header 

Detail – Without Merge Same 

Item Code 

(Tools -> Option -> Miscellaneous 

- Unticked ) 

Group Footer 

Page Footer 

Master Data 

Detail – Without Merge 

Same Item Code 
(Tools -> Option -> 

Miscellaneous - Unticked ) 
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2.3 Sample Layout on Preview Mode 

 

2.4 Print Position 

- Group Footer content will be printed at the pixel value input.  

- Higher Value = Higher Footer 

- without setting with print position, the group footer will be printed after the document 

detail records. 

Group Header 

Detail 

Group Footer 

Page Footer 



 

 

 

Fast Report Basic Guide 

 

8 
 

- Example Source Code: 

if Engine.FreeSpace < (GroupFooter1.Height + PageFooter1.Height + 30) then 

Engine.NewPage; 

Engine.CurY := Engine.PageHeight - GroupFooter1.Height - PageFooter1.Height -60 ; 

2.4.1 How to do the Print Position setting in Report? 

2.4.1.1 Click on Group Footer -> Click on Properties -> Event Tab -> Double Click on OnbeforePrint 

Event Name 

 
 

2.4.1.2 Adjust the value 

Higher Value = Higher Footer 
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2.5 Stop Position vs Print Count 

Stop Position Print Count 

Details will stop at the input value Details will stop by number of records 

inputs 

Recommend Not recommend if using More Description 

Value in Pixel Number of Records 

 

2.5.1 How to do the Stop Position in Report? 

2.5.1.1 Right click DetailData1 -> Click on Events Tab -> Double click onAfterCalcHeight name 

 
2.5.1.2 Setting the stop position  

 

2.5.2 How to do the Print Count setting in Report? 

2.5.2.1 Right click DetailData1 -> Click on Events Tab -> Double click onAfterCalcHeight 

name 
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2.5.2.2 Set number of records 

 

Small Tips : 

i) Set Either Print Count or Stop Position 

ii)  use // to disable the command 

iii)  When you set both Print Count and Stop Position, system will capture Print Count. 
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2.5.3 Sample on Print Position / Stop Position 
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3. How to design Simple Sales Invoice? 
➔ i) Preview Invoice 

➔ ii) Click on Report Name to enter to Design Mode 

 

 

3.1 Add PICTURE 

3.1.1 Click on Picture Object 

 
 

3.1.2 Place on Report Page   

 
 

i) Fix Picture 
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3.1.3 Click on Load 

 
3.1.4 Select the Picture on your local drive 

3.1.5 Click on  

 
3.1.6 Adjust to the desire size 

 
 

ii) Capture Picture from Report Dataset 
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3.2 Text Memo 

- Add Customer Email Address 

3.2.1 Click on Text Memo  

 
3.2.2 Place on Report Page  
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3.2.3 Enter Text : Email  

 
 

3.2.4 Repeat Step 3.2.1 & 3.2.2 

3.2.5 Select Document_CompanyBranch -> Email Expression 

 

3.3 Rich Text Object 

- Add Note  

3.3.1 Click on RichText Object 

 
3.3.2 Place on Report Page 

3.3.3 Select Main -> Note 
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3.4 System Text 

- Add Sum Qty 

3.4.1 Click on System Text Object 

 
3.4.2 Place on the Report Page 

3.4.3 Select Aggregate value  

 

3.5 Draw Line 

3.5.1 Click on Line 

 
3.5.2 Place on the Report Page 
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3.5.3 Draw a line 

 

3.6 Center Horizontally in Band 

- Display the object in center horizontal 

3.6.1 Click on Object you want to show in center horizontal 

3.6.2 Click on Center Horizontally In Band  

 
3.6.3 Done 

 



 

 

 

Fast Report Basic Guide 

 

18 
 

3.7 Align Left / Middle / Right 

3.7.1 Click on the multiple Object to Align as same alignment. System will follow the first object 

as alignment 

 
3.7.2 Done 
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3.8  Save the File 

1. File -> Save As -> Enter Report Name -> Save 

2. Preview and see the result 

Result: 
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4. How to create the Subreport in Report? 
 

-> Preview Invoice 

-> Click on Report Name to enter to Design Mode 

 

 

4.1 Click on Subreport Object 

 
 

4.1.1 Place on Report Page you want to show. 
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4.2 System will prompt a new blank page for Subreport 

 
 

4.3 Click on Insert Band to design the layout or insert the data 
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**May refer 2.1 Understand Bands at Page 4 on what band to use
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5. Check Box 
5.1 Simple CheckBox 
5.1.1 Click on CheckBox object 

 
 

5.1.2 Place on the place you want to show. 
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5.1.3 Press on the button 

 
 

5.1.4 Select the frame design 
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5.1.5 Change to False 

 
 

5.1.6 Save the File 

i) File -> Save As -> Enter Report Name -> Save 

ii) Preview and see the result 

Result: 
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5.2  Query to show Check Box  either True to False 
5.2.1 Click on CheckBox | Double Click OnBeforePrint 

 
 

5.2.2 Place a Query below 

 
 

Query : 

if <Main."UDF_updated"> = 'T' then 

 checkbox1.checked := true 

else 

 checkbox1.checked := false; 
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6. How to do Report Watermark? 

Step 1 : Insert Band | Select Overlay 
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Step 2 : Insert Picture / Text to load in the water mark 

 
 

Step 3 : Overlay size can drag the same size as A4/Letter,  and place the watermark on the 

position you want to show.  
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Step 3: File | Save As: Enter report name 

 

Step 4 : Preview and see the Result : 
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Frequently Ask Question(FAQ) 

1. Unit price is 0, display as FOC 
In Memo, enter following syntax : 

[FormatFloat(',0.00;-,0.00;FOC ',<Document_Detail."UnitPrice"> )] 

 

2. Document Currency Description Cents change to Sens 
[Document_Currency."Description"] : [StringReplace(CurrencyToLangWord(<Main."DocAmt">, 

<Profile."CurrencyLang">), 'CENTS', 'SENS', TRUE)] 
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3. More Description convert RichTextToPlainText 
Syntax :  

[RichTextToPlaintext(<Document_Detail."Description3">)] 

 

 

4. How to change report paper size? 
File -> Page Setting ->  
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5. if Qty > 10 , text color in red and in bold? 

 
5.1 Double Click on Memo 

5.2 Click on Highlight Tab 

5.3 Click on Add Button 



 

 

 

Fast Report Basic Guide 

 

35 
 

5.4 Expression value > 10 

 

5.5 Click on Font  

 Can set for Font Type, Font Style, Size, Color or Effects 
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5.6 Press OK 

5.7 Right Click on Memo,  Ticked Allow Expression 

Result : 
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6. Why in Report I have place at the position I want, but when preview it will 

show at bottom? 
- Right click on Memo, unticked Shift and Unticked Shift when Overlapped 
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7. Export to PDF Logo is blur 
Solution :

 

8. How to capture remark1 as url path? 
In Memo properties : 



 

 

 

Fast Report Basic Guide 

 

39 
 

Hyperlink Expression added in the Data Field Name 

 

Result :  
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9. Payslip to show AL or MC Only 
Step 1 : Click on SubReport3 

Step 2 : Right click on Leave MasterData Band 

 

Step 3 : Click on Filter button  

Step 4 : Enter the expression :  

(<Leave."LeaveType"> ='AL') OR (<Leave."LeaveType"> ='MC') 

Step 5 :  Press OK 

Step 6 : Press OK 
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10. How to get Net Unit Price 
Step 1 : Click on Memo Tex 

Step 2 : Place on Document Detail Band 

Step 3 : Drag data field from right to left box : 

[<Document_Detail."Amount"> / <Document_Detail."Qty">] 

Step 4 : Press OK 

Step 5 : Adjust the position 

Step 6:  Preview and see the result 

 

 

11.  UOM = UNIT, Qty display without Decimal Point, else with 2 Decimal Point. 
Step 1 : Click On Memo Text 

Step 2 : Copy the below syntax and Paste into Memo: 

[IIF(<Document_Detail."UOM"> = 'UNIT'>,  

FormatFloat('#,0;-#,0 ', <Document_Detail."Qty">) , 

FormatFloat('#,0.00;-#,0.00 ', <Document_Detail."Qty">))] 
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Step 4 : Press OK 

Step 5 : Result After Preview 
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12. How to Get Supplier Bank in Payment Voucher? 

 

Step 1 : Click on Memo  

Step 2 : Paste this syntax inside Memo 

[GetbankName(<pl_SUPPLIERBANKACC."Bank">)] 
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13. How to change the Amount in Word to First Character to Upper Case only? 

 
Can use function NameCase 

 

 

Before : 

 
After : 
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14. Long More Description cause report first page is Empty 
 

Step 1 : Right click at Detail Data1 > Ticked Allow Split 

 

Step 2 : Click on DetailData1 > Properties > Event Tab > Double Click on OnAfterCalcHeight 
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 Added // infront of if statement 

 

Step 3 :  Set Stop Position 

Click on DetailData1 > Double Click on Page1OnbeforePrint 

 

Add below Code inside procedure DetailData1OnBeforePrint(Sender: TfrxComponent); 

if Engine.FinalPass then begin 

     if <PAGE> <> <TOTALPAGES> then 

          PageFooter1.Height := 150 

     else 

         PageFooter1.Height := 0; //height on 0.3 inch * 96  

  end; 
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15. How do I format negative values to display in parentheses () instead of a 

dash(-) 

 

Step 1 : Double click on the Text Object 
 

 

 

Step 2 : place the Syntax as below > Press OK 

Sample syntax : [FormatFloat(DisplayFormat, ReportFieldName)] 

 

[FormatFloat('#,0.00;(#,0.00)' ,  <Document_Detail."Amount">)] 
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3. Select Display Format 
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4. Set the Display Format to Text(No Formatting) > Press OK 

 
5. Make sure got ticked Allow Expression 

 

 

 


